Dashboard / Digital Cockpit failed

Faults and Technical chat for the CUPRA Born
Post Reply
loz38
Posts: 5
Joined: Wed Feb 01, 2023 8:24 am

Post by loz38 »

On a long journey today my digital cockpit / dashboard stopped working - it just went black and didn’t come back while I was pulling into a charge station. I was able to charge but had to call out roadside assistance as I still had two hours left to drive. AA guy did two battery resets and it still wouldn’t work so he gave up and I decided to continue on home without it (thank god for the heads up display for speed). I’ll have to take it to the dealership this week.
Anyone else had this?

Cupra Born v3, 72 plate
Born V3 eBoost 77kwh delivered Jan 2023 | Tech L | PodPoint Solo

User avatar
Daveion
Posts: 429
Joined: Wed Jun 08, 2022 8:32 pm

Post by Daveion »

I've not heard of that particular fault before. Surprised the HUD still functioned.
Born V2-Tech L collected June 22
BMW Z4 e89 sDrive30i Highline
BMW Z4 e85 3.0i SE
Elea4
Posts: 203
Joined: Fri Jun 10, 2022 5:19 pm

Post by Elea4 »

Sorry if this is starting to sound like a mantra from me - pull fuse # 19 located in the interior fuse box. Wait a minute then plug it in again.
loz38
Posts: 5
Joined: Wed Feb 01, 2023 8:24 am

Post by loz38 »

Update: it was faulty or loose wiring tripping one of the fuses - fixed by the dealership.
Born V3 eBoost 77kwh delivered Jan 2023 | Tech L | PodPoint Solo
User avatar
Daveion
Posts: 429
Joined: Wed Jun 08, 2022 8:32 pm

Post by Daveion »

loz38 wrote: Mon Mar 20, 2023 8:49 am Update: it was faulty or loose wiring tripping one of the fuses - fixed by the dealership.
Hope that's the last problem you have.
Born V2-Tech L collected June 22
BMW Z4 e89 sDrive30i Highline
BMW Z4 e85 3.0i SE
Post Reply